aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCory Fields <cory-nospam-@coryfields.com>2017-02-21 11:56:07 -0500
committerCory Fields <cory-nospam-@coryfields.com>2017-02-21 11:56:07 -0500
commitb602fe0f7372256bd2bc8c116d23dee3253882f9 (patch)
tree430d03c8493bf6abcdd3ce055cda636dac81ec7a /configure.ac
parent5f0556d0326bf6f4d34f7e8b9ada7bbb09cb1df2 (diff)
downloadbitcoin-b602fe0f7372256bd2bc8c116d23dee3253882f9.tar.xz
build: warn about variable length arrays
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 78129fb202..6142796014 100644
--- a/configure.ac
+++ b/configure.ac
@@ -210,6 +210,7 @@ if test "x$CXXFLAGS_overridden" = "xno"; then
AX_CHECK_COMPILE_FLAG([-Wall],[CXXFLAGS="$CXXFLAGS -Wall"],,[[$CXXFLAG_WERROR]])
AX_CHECK_COMPILE_FLAG([-Wextra],[CXXFLAGS="$CXXFLAGS -Wextra"],,[[$CXXFLAG_WERROR]])
AX_CHECK_COMPILE_FLAG([-Wformat],[CXXFLAGS="$CXXFLAGS -Wformat"],,[[$CXXFLAG_WERROR]])
+ AX_CHECK_COMPILE_FLAG([-Wvla],[CXXFLAGS="$CXXFLAGS -Wvla"],,[[$CXXFLAG_WERROR]])
AX_CHECK_COMPILE_FLAG([-Wformat-security],[CXXFLAGS="$CXXFLAGS -Wformat-security"],,[[$CXXFLAG_WERROR]])
## Some compilers (gcc) ignore unknown -Wno-* options, but warn about all