aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorpracticalswift <practicalswift@users.noreply.github.com>2018-03-15 16:13:11 +0100
committerpracticalswift <practicalswift@users.noreply.github.com>2018-06-24 20:35:27 +0200
commit94e52d13db49405b1858090041fdf9af49096d43 (patch)
treeee548605894773078a969fb5cd89cb4d191353e8 /configure.ac
parentb1dc39df6ec878d06fc7217a3d7bf07397edf3ea (diff)
downloadbitcoin-94e52d13db49405b1858090041fdf9af49096d43.tar.xz
Add -ftrapv to DEBUG_CXXFLAGS when --enable-debug is used
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ff7f1b39c8..e4142f5762 100644
--- a/configure.ac
+++ b/configure.ac
@@ -263,6 +263,7 @@ if test "x$enable_debug" = xyes; then
AX_CHECK_PREPROC_FLAG([-DDEBUG],[[DEBUG_CPPFLAGS="$DEBUG_CPPFLAGS -DDEBUG"]],,[[$CXXFLAG_WERROR]])
AX_CHECK_PREPROC_FLAG([-DDEBUG_LOCKORDER],[[DEBUG_CPPFLAGS="$DEBUG_CPPFLAGS -DDEBUG_LOCKORDER"]],,[[$CXXFLAG_WERROR]])
+ AX_CHECK_COMPILE_FLAG([-ftrapv],[DEBUG_CXXFLAGS="$DEBUG_CXXFLAGS -ftrapv"],,[[$CXXFLAG_WERROR]])
fi
if test x$use_sanitizers != x; then