aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRené Nyffenegger <mail@renenyffenegger.ch>2017-07-07 16:54:11 +0200
committerRené Nyffenegger <mail@renenyffenegger.ch>2017-07-15 22:30:58 +0200
commit912da1dcc8e52228582f36b0010b498ebc76754b (patch)
tree454f14d953737c49588a7081095d3dcab39f5938 /configure.ac
parentd3b58704d1d325875fc605580c1c02b825c1bbcc (diff)
downloadbitcoin-912da1dcc8e52228582f36b0010b498ebc76754b.tar.xz
Use AC_ARG_VAR to set ARFLAGS.
The user can set ARFLAGS in the ./configure step with ./configure ARFLAGS=... If he chooses not to do so, ARFLAGS will be set to cr.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a90063d9de..e8a8b134b8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -19,6 +19,12 @@ BITCOIN_GUI_NAME=bitcoin-qt
BITCOIN_CLI_NAME=bitcoin-cli
BITCOIN_TX_NAME=bitcoin-tx
+dnl Unless the user specified ARFLAGS, force it to be cr
+AC_ARG_VAR(ARFLAGS, [Flags for the archiver, defaults to <cr> if not set])
+if test "x${ARFLAGS+set}" != "xset"; then
+ ARFLAGS="cr"
+fi
+
AC_CANONICAL_HOST
AH_TOP([#ifndef BITCOIN_CONFIG_H])
@@ -1262,4 +1268,5 @@ echo " CPPFLAGS = $CPPFLAGS"
echo " CXX = $CXX"
echo " CXXFLAGS = $CXXFLAGS"
echo " LDFLAGS = $LDFLAGS"
+echo " ARFLAGS = $ARFLAGS"
echo