aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWladimir J. van der Laan <laanwj@gmail.com>2014-06-06 07:23:45 +0200
committerWladimir J. van der Laan <laanwj@gmail.com>2014-06-06 08:04:20 +0200
commit71c0e80e7e9a3be015a0e91616778698051a0785 (patch)
tree63e413662875b7abbff65408454b20ea5625a521 /configure.ac
parent5795aaca26d23d315f80ee0b45f1e1fa939e5cfd (diff)
parentefe6888407186b8a468f357fa7084c0a8c3de503 (diff)
Merge pull request #4241
efe6888 build: fix version dependency (Cory Fields) f4d8112 build: quit abusing AM_CPPFLAGS (Cory Fields) 56c157d build: avoid the use of top_ and abs_ dir paths (Cory Fields) 70c71c5 build: Tidy up file generation output (Cory Fields) 6b9f0d5 build: nuke Makefile.include from orbit (Cory Fields) 8b09ef7 build: add stub makefiles for easier subdir builds (Cory Fields) be4e9ae build: delete old Makefile.am's (Cory Fields) 65e8ba4 build: Switch to non-recursive make (Cory Fields)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3a8d33a5a0..d8521ad3ad 100644
--- a/configure.ac
+++ b/configure.ac
@@ -666,6 +666,9 @@ AM_CONDITIONAL([TARGET_DARWIN], [test x$TARGET_OS = xdarwin])
AM_CONDITIONAL([BUILD_DARWIN], [test x$BUILD_OS = xdarwin])
AM_CONDITIONAL([TARGET_WINDOWS], [test x$TARGET_OS = xwindows])
AM_CONDITIONAL([ENABLE_WALLET],[test x$enable_wallet == xyes])
+AM_CONDITIONAL([ENABLE_TESTS],[test x$use_tests == xyes])
+AM_CONDITIONAL([ENABLE_QT],[test x$bitcoin_enable_qt == xyes])
+AM_CONDITIONAL([ENABLE_QT_TESTS],[test x$use_tests$bitcoin_enable_qt_test = xyesyes])
AM_CONDITIONAL([USE_QRCODE], [test x$use_qr = xyes])
AM_CONDITIONAL([USE_LCOV],[test x$use_lcov == xyes])
AM_CONDITIONAL([USE_COMPARISON_TOOL],[test x$use_comparison_tool != xno])
@@ -695,7 +698,7 @@ AC_SUBST(LEVELDB_TARGET_FLAGS)
AC_SUBST(BUILD_TEST)
AC_SUBST(BUILD_QT)
AC_SUBST(BUILD_TEST_QT)
-AC_CONFIG_FILES([Makefile src/Makefile src/test/Makefile src/qt/Makefile src/qt/test/Makefile share/setup.nsi share/qt/Info.plist])
+AC_CONFIG_FILES([Makefile src/Makefile share/setup.nsi share/qt/Info.plist])
AC_CONFIG_FILES([qa/pull-tester/run-bitcoind-for-test.sh],[chmod +x qa/pull-tester/run-bitcoind-for-test.sh])
AC_CONFIG_FILES([qa/pull-tester/build-tests.sh],[chmod +x qa/pull-tester/build-tests.sh])
AC_OUTPUT