aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Raviv <dan@soundradix.com>2017-08-26 21:09:00 +0300
committerDan Raviv <dan@soundradix.com>2017-08-26 21:09:00 +0300
commit5ac072caa242d7ecf724e0c3a23f4a7c477a3a1e (patch)
treea2976be6e6b5d263eb6d7a0576f3f1e91dbe19d6 /configure.ac
parent7fd49d01dc2ea444ba4d81d0cfa17486b03c8515 (diff)
downloadbitcoin-5ac072caa242d7ecf724e0c3a23f4a7c477a3a1e.tar.xz
Fix boost headers included as user instead of system headers
In most of the project, boost headers are included as system headers. Fix the few inconsistent places where they aren't.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index e5ed938947..4513099d58 100644
--- a/configure.ac
+++ b/configure.ac
@@ -827,14 +827,14 @@ TEMP_CPPFLAGS="$CPPFLAGS"
CPPFLAGS="$CPPFLAGS $BOOST_CPPFLAGS"
AC_MSG_CHECKING([for mismatched boost c++11 scoped enums])
AC_LINK_IFELSE([AC_LANG_PROGRAM([[
- #include "boost/config.hpp"
- #include "boost/version.hpp"
+ #include <boost/config.hpp>
+ #include <boost/version.hpp>
#if !defined(BOOST_NO_SCOPED_ENUMS) && !defined(BOOST_NO_CXX11_SCOPED_ENUMS) && BOOST_VERSION < 105700
#define BOOST_NO_SCOPED_ENUMS
#define BOOST_NO_CXX11_SCOPED_ENUMS
#define CHECK
#endif
- #include "boost/filesystem.hpp"
+ #include <boost/filesystem.hpp>
]],[[
#if defined(CHECK)
boost::filesystem::copy_file("foo", "bar");