aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChun Kuan Lee <ken2812221@gmail.com>2018-07-01 13:58:37 +0000
committerChun Kuan Lee <ken2812221@gmail.com>2018-07-01 15:37:28 +0000
commit49d1f4cdde6d3289cb8c18ad35fc739371e25388 (patch)
tree94b199414d29ad742b3ed089a5014123cd03d922 /configure.ac
parent686e97a0c7358291d628213447cf33e99cde7ce8 (diff)
downloadbitcoin-49d1f4cdde6d3289cb8c18ad35fc739371e25388.tar.xz
Detect if char equals int8_t
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e4142f5762..9fba9d0851 100644
--- a/configure.ac
+++ b/configure.ac
@@ -808,6 +808,14 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <sys/types.h>
[ AC_MSG_RESULT(no)]
)
+AC_MSG_CHECKING(for if type char equals int8_t)
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <stdint.h>
+ #include <type_traits>]],
+ [[ static_assert(std::is_same<int8_t, char>::value, ""); ]])],
+ [ AC_MSG_RESULT(yes); AC_DEFINE(CHAR_EQUALS_INT8, 1,[Define this symbol if type char equals int8_t]) ],
+ [ AC_MSG_RESULT(no)]
+)
+
# Check for reduced exports
if test x$use_reduce_exports = xyes; then
AX_CHECK_COMPILE_FLAG([-fvisibility=hidden],[RE_CXXFLAGS="-fvisibility=hidden"],