aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCory Fields <cory-nospam-@coryfields.com>2014-08-20 21:02:55 -0400
committerCory Fields <cory-nospam-@coryfields.com>2014-08-21 13:12:00 -0400
commit386efb7695debaf5f0f328a2e4c9abc342161665 (patch)
tree4cfca1b39c16a8777881ace6cdbbc0f4ca2e63bc /configure.ac
parent752f2b36c8796eac6c0b48aa1917718d736ff88d (diff)
downloadbitcoin-386efb7695debaf5f0f328a2e4c9abc342161665.tar.xz
build: work around ccache/autotools warning-spamming bug
When using clang and ccache, builds spew lots of: Clang: warning: argument unused during compilation Upstream bug: https://bugzilla.samba.org/show_bug.cgi?id=8118 This is harmless, bug annoying. If ccache is being used and the -Qunused-arguments flag is supported (clang), use it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 601ccf0a79..700f4ab709 100644
--- a/configure.ac
+++ b/configure.ac
@@ -656,6 +656,9 @@ if test "x$use_ccache" != "xno"; then
fi
AC_MSG_RESULT($use_ccache)
fi
+if test "x$use_ccache" = "xyes"; then
+ AX_CHECK_PREPROC_FLAG([-Qunused-arguments],[CPPFLAGS="-Qunused-arguments $CPPFLAGS"])
+fi
dnl enable wallet
AC_MSG_CHECKING([if wallet should be enabled])