aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCory Fields <cory-nospam-@coryfields.com>2014-10-13 21:59:59 -0400
committerCory Fields <cory-nospam-@coryfields.com>2014-10-14 20:45:20 -0400
commit1723862e82926ef24ccf1d098dc02933f893cf48 (patch)
tree28e1d0c20754d20532c59db0a8b2d1b167c5eb20 /configure.ac
parent28d412ff20309b275da1375839dae0ee236a5ac2 (diff)
downloadbitcoin-1723862e82926ef24ccf1d098dc02933f893cf48.tar.xz
build: fix libtool's refusal to link static libs into a dll
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 14 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index dbc86c6f39..b603d1766d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11,8 +11,21 @@ AC_CONFIG_SRCDIR([src/main.cpp])
AC_CONFIG_HEADERS([src/config/bitcoin-config.h])
AC_CONFIG_AUX_DIR([build-aux])
AC_CONFIG_MACRO_DIR([build-aux/m4])
-LT_INIT([disable-shared])
+
AC_CANONICAL_HOST
+
+dnl By default, libtool for mingw refuses to link static libs into a dll for
+dnl fear of mixing pic/non-pic objects, and import/export complications. Since
+dnl we have those under control, re-enable that functionality.
+
+case $host in
+ *mingw*)
+ lt_cv_deplibs_check_method="pass_all"
+ ;;
+esac
+
+LT_INIT([disable-shared])
+
AH_TOP([#ifndef BITCOIN_CONFIG_H])
AH_TOP([#define BITCOIN_CONFIG_H])
AH_BOTTOM([#endif //BITCOIN_CONFIG_H])