aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWladimir J. van der Laan <laanwj@gmail.com>2014-01-15 23:28:41 +0100
committerWladimir J. van der Laan <laanwj@gmail.com>2014-01-16 12:44:59 +0100
commit0d40f5a6be7bfb7e874994bf5f68dc72f86eaa6d (patch)
tree5995927e8880827dded1d1f843e46d9881447a9c /configure.ac
parente4b991e56d2e1984fb66792254e8fbaa384ff789 (diff)
downloadbitcoin-0d40f5a6be7bfb7e874994bf5f68dc72f86eaa6d.tar.xz
build: Allow providing extra libs for Boost Chrono
Pass BOOST_CHRONO_EXTRALIBS to give extra dependency libraries for Boost Chrono which are not auto-detected.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2261addaef..fa0a6dd1f4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -373,6 +373,9 @@ dnl after 1.56.
dnl If neither is available, abort.
dnl If sleep_for is used, boost_chrono becomes a requirement.
if test x$ax_cv_boost_chrono = xyes; then
+dnl Allow passing extra needed dependency libraries for boost-chrono from static gitian build
+BOOST_CHRONO_LIB="$BOOST_CHRONO_LIB $BOOST_CHRONO_EXTRALIBS"
+
TEMP_LIBS="$LIBS"
LIBS="$LIBS $BOOST_LIBS $BOOST_CHRONO_LIB"
AC_TRY_LINK([