aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJohn Newbery <john@johnnewbery.com>2017-03-09 09:55:12 -0500
committerJohn Newbery <john@johnnewbery.com>2017-03-20 10:40:31 -0400
commit5b0bff4581cf5cbecce35df46075ba256b4974f5 (patch)
treef814ff7fdec4cf89dbe2de8bbf458c2e0fb1824d /configure.ac
parenta9bd622a658b41b219912288e643f5e2c1b145b4 (diff)
downloadbitcoin-5b0bff4581cf5cbecce35df46075ba256b4974f5.tar.xz
Rename --enable-extended-rpc-tests to --enable-extended-functional-tests
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index b5120257d9..cd1d4204c1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -124,10 +124,10 @@ AC_ARG_ENABLE(bench,
[use_bench=$enableval],
[use_bench=yes])
-AC_ARG_ENABLE([extended-rpc-tests],
- AS_HELP_STRING([--enable-extended-rpc-tests],[enable expensive RPC tests when using lcov (default no)]),
- [use_extended_rpc_tests=$enableval],
- [use_extended_rpc_tests=no])
+AC_ARG_ENABLE([extended-functional-tests],
+ AS_HELP_STRING([--enable-extended-functional-tests],[enable expensive functional tests when using lcov (default no)]),
+ [use_extended_functional_tests=$enableval],
+ [use_extended_functional_tests=no])
AC_ARG_WITH([qrencode],
[AS_HELP_STRING([--with-qrencode],
@@ -414,8 +414,8 @@ if test x$use_pkgconfig = xyes; then
])
fi
-if test x$use_extended_rpc_tests != xno; then
- AC_SUBST(EXTENDED_RPC_TESTS, -extended)
+if test x$use_extended_functional_tests != xno; then
+ AC_SUBST(EXTENDED_FUNCTIONAL_TESTS, --extended)
fi
if test x$use_lcov = xyes; then