aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2024-08-05 14:46:12 +0100
committerfanquake <fanquake@gmail.com>2024-08-05 14:54:55 +0100
commit37c9abdc4375ce1a1b9186a63e8c133fbb7feebd (patch)
treef8c94bca00359963e590ea05612314f3c0bd8953 /configure.ac
parent42326b0fa46a67ad278cef7709a29feb05ce0110 (diff)
build: remove check for __attribute__((visibility..
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 0 insertions, 17 deletions
diff --git a/configure.ac b/configure.ac
index 439bb508e7..d761911573 100644
--- a/configure.ac
+++ b/configure.ac
@@ -943,23 +943,6 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
[ AC_MSG_RESULT([no])]
)
-AC_MSG_CHECKING([for default visibility attribute])
-AC_COMPILE_IFELSE([AC_LANG_SOURCE([
- int foo(void) __attribute__((visibility("default")));
- int main(){}
- ])],
- [
- AC_DEFINE([HAVE_DEFAULT_VISIBILITY_ATTRIBUTE], [1], [Define if the visibility attribute is supported.])
- AC_MSG_RESULT([yes])
- ],
- [
- AC_MSG_RESULT([no])
- if test "$use_reduce_exports" = "yes"; then
- AC_MSG_ERROR([Cannot find a working visibility attribute. Use --disable-reduce-exports.])
- fi
- ]
-)
-
AC_MSG_CHECKING([for dllexport attribute])
AC_COMPILE_IFELSE([AC_LANG_SOURCE([
__declspec(dllexport) int foo(void);