aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCory Fields <cory-nospam-@coryfields.com>2014-06-09 15:05:28 -0400
committerPieter Wuille <pieter.wuille@gmail.com>2014-06-21 19:47:43 +0200
commitf2647cc0e997198d7ac7f3fe3d843e941b57dda8 (patch)
tree16913935f9312f78643dd1adf5e1227820605ee0 /configure.ac
parent54372482a8ffa363f5dd9ff1c80141a168109ed5 (diff)
downloadbitcoin-f2647cc0e997198d7ac7f3fe3d843e941b57dda8.tar.xz
crypto: explicitly check for byte read/write functions
Don't depend on hard-coded platform lists
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0caf653cad..811ef1dd80 100644
--- a/configure.ac
+++ b/configure.ac
@@ -368,7 +368,12 @@ if test x$TARGET_OS = xdarwin; then
AX_CHECK_LINK_FLAG([[-Wl,-dead_strip]], [LDFLAGS="$LDFLAGS -Wl,-dead_strip"])
fi
-AC_CHECK_HEADERS([stdio.h stdlib.h unistd.h strings.h sys/types.h sys/stat.h sys/select.h])
+AC_CHECK_HEADERS([endian.h stdio.h stdlib.h unistd.h strings.h sys/types.h sys/stat.h sys/select.h])
+
+AC_CHECK_DECLS([le32toh, le64toh, htole32, htole64, be32toh, be64toh, htobe32, htobe64],,,
+ [#if HAVE_ENDIAN_H
+ #include <endian.h>
+ #endif])
dnl Check for MSG_NOSIGNAL
AC_MSG_CHECKING(for MSG_NOSIGNAL)