aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDouglas Roark <doug@bloq.com>2016-12-24 12:27:39 -0800
committerDouglas Roark <doug@bloq.com>2016-12-28 21:47:51 -0800
commite2b5c98cefc45a1404d4ec3230860f2e1c5df0c9 (patch)
tree79b8904e9b0b3e5f718a81ec9bedfdce1595f037 /configure.ac
parentdce853ef76ef90c46d84294225088d595467d08c (diff)
downloadbitcoin-e2b5c98cefc45a1404d4ec3230860f2e1c5df0c9.tar.xz
Fix linker error when configured with --enable-lcov
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ced258e02e..9d2817db43 100644
--- a/configure.ac
+++ b/configure.ac
@@ -414,6 +414,8 @@ if test x$use_lcov = xyes; then
AC_MSG_ERROR("lcov testing requested but genhtml not found")
fi
LCOV="$LCOV --gcov-tool=$GCOV"
+ AX_CHECK_LINK_FLAG([[--coverage]], [LDFLAGS="$LDFLAGS --coverage"],
+ [AC_MSG_ERROR("lcov testing requested but --coverage linker flag does not work")])
AX_CHECK_COMPILE_FLAG([--coverage],[CXXFLAGS="$CXXFLAGS --coverage"],
[AC_MSG_ERROR("lcov testing requested but --coverage flag does not work")])
fi