aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuke Dashjr <luke-jr+git@utopios.org>2017-01-04 17:07:42 +0000
committerLuke Dashjr <luke-jr+git@utopios.org>2017-01-04 18:37:37 +0000
commit0388afe69dd85ca9549727ee105ba7017169b464 (patch)
tree2d8193433c62f7a91613f5845e03e5f1a028c594 /configure.ac
parentb05b1af10b9a5298bd90bea439f0fd6c636e0cfa (diff)
downloadbitcoin-0388afe69dd85ca9549727ee105ba7017169b464.tar.xz
Let autoconf detect presence of EVP_MD_CTX_new
Fixes LibreSSL compatibility
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ced258e02e..02af0d638d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -832,6 +832,13 @@ else
fi
fi
+save_CXXFLAGS="${CXXFLAGS}"
+CXXFLAGS="${CXXFLAGS} ${CRYPTO_CFLAGS} ${SSL_CFLAGS}"
+AC_CHECK_DECLS([EVP_MD_CTX_new],,,[AC_INCLUDES_DEFAULT
+#include <openssl/x509_vfy.h>
+])
+CXXFLAGS="${save_CXXFLAGS}"
+
dnl univalue check
need_bundled_univalue=yes