aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCory Fields <cory-nospam-@coryfields.com>2016-04-28 17:46:35 -0400
committerCory Fields <cory-nospam-@coryfields.com>2016-04-30 17:46:35 -0400
commitde982901555b3f168a721a8911dc1ce8a51d3f59 (patch)
treee1dc02bd782305075b0d2aeab40445cf49202857 /configure.ac
parent0ad104190465d8d65c2344bbe10dcf3df025d86c (diff)
downloadbitcoin-de982901555b3f168a721a8911dc1ce8a51d3f59.tar.xz
build: No need to check for leveldb atomics
They're guaranteed with c++11
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 0 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index 558835bbbd..a1c04daf53 100644
--- a/configure.ac
+++ b/configure.ac
@@ -555,18 +555,6 @@ if test x$use_reduce_exports = xyes; then
[AC_MSG_ERROR([Cannot set default symbol visibility. Use --disable-reduce-exports.])])
fi
-dnl This can go away when we require c++11
-TEMP_CXXFLAGS="$CXXFLAGS"
-CXXFLAGS="$CXXFLAGS -std=c++0x"
-AC_MSG_CHECKING(for c++11 atomics)
-AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
- #include <atomic>
- ]],[[]])],
- [ AC_MSG_RESULT(yes); LEVELDB_ATOMIC_CPPFLAGS="-DLEVELDB_ATOMIC_PRESENT"; LEVELDB_ATOMIC_CXXFLAGS="-std=c++0x"],
- [ AC_MSG_RESULT(no)]
-)
-CXXFLAGS="$TEMP_CXXFLAGS"
-
LEVELDB_CPPFLAGS=
LIBLEVELDB=
LIBMEMENV=
@@ -1069,8 +1057,6 @@ AC_SUBST(TESTDEFS)
AC_SUBST(LEVELDB_TARGET_FLAGS)
AC_SUBST(MINIUPNPC_CPPFLAGS)
AC_SUBST(MINIUPNPC_LIBS)
-AC_SUBST(LEVELDB_ATOMIC_CPPFLAGS)
-AC_SUBST(LEVELDB_ATOMIC_CXXFLAGS)
AC_CONFIG_FILES([Makefile src/Makefile share/setup.nsi share/qt/Info.plist src/test/buildenv.py])
AC_CONFIG_FILES([qa/pull-tester/run-bitcoind-for-test.sh],[chmod +x qa/pull-tester/run-bitcoind-for-test.sh])
AC_CONFIG_FILES([qa/pull-tester/tests_config.py],[chmod +x qa/pull-tester/tests_config.py])