aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2023-05-18 14:59:14 +0100
committerHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2023-05-18 14:59:14 +0100
commitb53cab0083d99e9610d74517d1d41fc615953770 (patch)
treecdaa1c95a0e395decf8cc477d67d47a9a8763cd6 /configure.ac
parentccc431d53ea05081e8f827d6165221129f362ebb (diff)
build: Detect USDT the same way how it is used in the code
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 8e73213c78..94d6f7dba7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1412,7 +1412,9 @@ if test "$use_usdt" != "no"; then
AC_COMPILE_IFELSE([
AC_LANG_PROGRAM(
[#include <sys/sdt.h>],
- [DTRACE_PROBE("context", "event");]
+ [DTRACE_PROBE(context, event);
+ int a, b, c, d, e, f, g;
+ DTRACE_PROBE7(context, event, a, b, c, d, e, f, g);]
)],
[AC_MSG_RESULT([yes]); AC_DEFINE([ENABLE_TRACING], [1], [Define to 1 to enable tracepoints for Userspace, Statically Defined Tracing])],
[AC_MSG_RESULT([no]); use_usdt=no;]