aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWladimir J. van der Laan <laanwj@gmail.com>2016-11-17 16:05:53 +0100
committerWladimir J. van der Laan <laanwj@gmail.com>2016-11-17 16:05:56 +0100
commita8b2a82618bec43977a65c076f691ec1cddd54be (patch)
tree2a4ae76dcb93af292e97a2f6559add57e5680f1d /configure.ac
parentaaca05c0dabdffc0da589f8cf3e7e7a6a771b35c (diff)
parentd8274bcd00865d829808e8e05651c61dff7ccac0 (diff)
downloadbitcoin-a8b2a82618bec43977a65c076f691ec1cddd54be.tar.xz
Merge #9156: Add compile and link options echo to configure
d8274bc Add compile and link options echo to configure (Jonas Schnelli)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 25 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7347277a56..319e1afe27 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1134,3 +1134,28 @@ case ${OS} in
mv qa/pull-tester/tests_config-2.py qa/pull-tester/tests_config.py
;;
esac
+
+echo
+echo "Options used to compile and link:"
+echo " with wallet = $enable_wallet"
+echo " with gui / qt = $bitcoin_enable_qt"
+if test x$bitcoin_enable_qt != xno; then
+ echo " qt version = $bitcoin_qt_got_major_vers"
+ echo " with qr = $use_qr"
+fi
+echo " with zmq = $use_zmq"
+echo " with test = $use_tests"
+echo " with bench = $use_bench"
+echo " with upnp = $use_upnp"
+echo " debug enabled = $enable_debug"
+echo
+echo " target os = $TARGET_OS"
+echo " build os = $BUILD_OS"
+echo
+echo " CC = $CC"
+echo " CFLAGS = $CFLAGS"
+echo " CPPFLAGS = $CPPFLAGS"
+echo " CXX = $CXX"
+echo " CXXFLAGS = $CXXFLAGS"
+echo " LDFLAGS = $LDFLAGS"
+echo