aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2016-06-22 17:56:07 +0800
committerfanquake <fanquake@gmail.com>2016-07-21 16:20:17 +0800
commita615386552f9981dc024cc4a0df758f8b0fda4d8 (patch)
tree9c10f521cff8dc9b9be0a5f2377fd703b13a1479 /configure.ac
parent8e048f40cc25b6ad3f49d2828c8562b657d91ced (diff)
downloadbitcoin-a615386552f9981dc024cc4a0df758f8b0fda4d8.tar.xz
[depends] ZeroMQ 4.1.5
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 78d63f9272..ef58cfc40d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -816,6 +816,15 @@ else
AC_DEFINE_UNQUOTED([ENABLE_ZMQ],[0],[Define to 1 to enable ZMQ functions])
fi
+ if test "x$use_zmq" = "xyes"; then
+ dnl Assume libzmq was built for static linking
+ case $host in
+ *mingw*)
+ ZMQ_CFLAGS="$ZMQ_CFLAGS -DZMQ_STATIC"
+ ;;
+ esac
+ fi
+
BITCOIN_QT_CHECK(AC_CHECK_LIB([protobuf] ,[main],[PROTOBUF_LIBS=-lprotobuf], BITCOIN_QT_FAIL(libprotobuf not found)))
if test x$use_qr != xno; then
BITCOIN_QT_CHECK([AC_CHECK_LIB([qrencode], [main],[QR_LIBS=-lqrencode], [have_qrencode=no])])