aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCory Fields <cory-nospam-@coryfields.com>2016-11-15 16:12:17 -0500
committerWladimir J. van der Laan <laanwj@gmail.com>2016-12-02 08:38:02 +0100
commitd1b4da9259ded1776479ac97b30d8eaa6747ee71 (patch)
treea32204800b70b638fca5e136c03c17d9eaed8c50 /configure.ac
parent29435db6a4b5ddfca3b83d49a03643439d8f254f (diff)
downloadbitcoin-d1b4da9259ded1776479ac97b30d8eaa6747ee71.tar.xz
build: fix qt5.7 build under macOS
OBJCXX's std flags don't get defined by our cxx macro. Rather than hard-coding to c++11, just force OBJCXX to be the same as CXX unless the user specified otherwise. Github-Pull: #9169 Rebased-From: 70266e98292bf9c8f019ca4b11d681b575f71448
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b091c74b75..41b42126e6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -45,7 +45,6 @@ else
CXXFLAGS_overridden=no
fi
AC_PROG_CXX
-m4_ifdef([AC_PROG_OBJCXX],[AC_PROG_OBJCXX])
dnl By default, libtool for mingw refuses to link static libs into a dll for
dnl fear of mixing pic/non-pic objects, and import/export complications. Since
@@ -60,6 +59,15 @@ AX_CXX_COMPILE_STDCXX([11], [noext], [mandatory])
dnl Check if -latomic is required for <std::atomic>
CHECK_ATOMIC
+dnl Unless the user specified OBJCXX, force it to be the same as CXX. This ensures
+dnl that we get the same -std flags for both.
+m4_ifdef([AC_PROG_OBJCXX],[
+if test "x${OBJCXX+set}" = "x"; then
+ OBJCXX="${CXX}"
+fi
+AC_PROG_OBJCXX
+])
+
dnl Libtool init checks.
LT_INIT([pic-only])