aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWladimir J. van der Laan <laanwj@gmail.com>2015-10-01 23:05:31 +0200
committerWladimir J. van der Laan <laanwj@gmail.com>2015-10-01 23:06:02 +0200
commit5ab5dca6f1bb1eccd47ea64834acc4fee0435b73 (patch)
tree89bfbe4aa2375b8e37275707f458a45d4a183d85 /configure.ac
parent19c71864258f55b07dd290d8740715c4707222f2 (diff)
parent5467820be5404fa736436a1202079e764a4308b4 (diff)
downloadbitcoin-5ab5dca6f1bb1eccd47ea64834acc4fee0435b73.tar.xz
Merge pull request #6616
5467820 Migrated rpc-tests.sh to all python rpc-tests.py (ptschip)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 11 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ff2c7ab4e9..9a1029e79f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -899,7 +899,8 @@ AC_SUBST(MINIUPNPC_CPPFLAGS)
AC_SUBST(MINIUPNPC_LIBS)
AC_CONFIG_FILES([Makefile src/Makefile share/setup.nsi share/qt/Info.plist src/test/buildenv.py])
AC_CONFIG_FILES([qa/pull-tester/run-bitcoind-for-test.sh],[chmod +x qa/pull-tester/run-bitcoind-for-test.sh])
-AC_CONFIG_FILES([qa/pull-tester/tests-config.sh],[chmod +x qa/pull-tester/tests-config.sh])
+AC_CONFIG_FILES([qa/pull-tester/tests_config.py],[chmod +x qa/pull-tester/tests_config.py])
+chmod +x qa/pull-tester/rpc-tests.py
dnl boost's m4 checks do something really nasty: they export these vars. As a
dnl result, they leak into secp256k1's configure and crazy things happen.
@@ -939,3 +940,12 @@ case $host in
chmod 755 libtool
;;
esac
+
+dnl Replace the BUILDDIR path with the correct Windows path if compiling on Native Windows
+case ${OS} in
+ *Windows*)
+ sed 's/BUILDDIR="\/\([[a-z]]\)/BUILDDIR="\1:/' qa/pull-tester/tests_config.py > qa/pull-tester/tests_config-2.py
+ mv qa/pull-tester/tests_config-2.py qa/pull-tester/tests_config.py
+ chmod +x qa/pull-tester/tests_config.py
+ ;;
+esac