aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWladimir J. van der Laan <laanwj@gmail.com>2014-08-12 13:03:56 +0200
committerWladimir J. van der Laan <laanwj@gmail.com>2014-08-12 13:04:55 +0200
commit4c61ba40b9fccb197aae4e6443d564a5e2a501a6 (patch)
tree4750dc16e2b9980aa7f0c39025cccf2144b7984e /configure.ac
parent76c49c4138dcd30c9237fbb0842df8d2f8209319 (diff)
downloadbitcoin-4c61ba40b9fccb197aae4e6443d564a5e2a501a6.tar.xz
build: check for sys/prctl.h in the proper way
Use AC_CHECK_HEADERS to check for the header, and include it only if detected and the subsequent HAVE_SYS_PRCTL_H is set.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ffd05ae4f8..55fc091bc5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -378,7 +378,7 @@ if test x$TARGET_OS = xdarwin; then
AX_CHECK_LINK_FLAG([[-Wl,-dead_strip]], [LDFLAGS="$LDFLAGS -Wl,-dead_strip"])
fi
-AC_CHECK_HEADERS([endian.h stdio.h stdlib.h unistd.h strings.h sys/types.h sys/stat.h sys/select.h])
+AC_CHECK_HEADERS([endian.h stdio.h stdlib.h unistd.h strings.h sys/types.h sys/stat.h sys/select.h sys/prctl.h])
AC_SEARCH_LIBS([getaddrinfo_a], [anl], [AC_DEFINE(HAVE_GETADDRINFO_A, 1, [Define this symbol if you have getaddrinfo_a])])
AC_SEARCH_LIBS([inet_pton], [nsl resolv], [AC_DEFINE(HAVE_INET_PTON, 1, [Define this symbol if you have inet_pton])])