aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCory Fields <cory-nospam-@coryfields.com>2014-10-14 17:31:16 -0400
committerCory Fields <cory-nospam-@coryfields.com>2014-11-19 22:08:27 -0500
commitf36a40f7fd948781656e730338a1ae647e7c4928 (patch)
treea292ea5a4f6d21e4ce17b6dc1db2531cb91b5403 /configure.ac
parent811a765bef5701b167ce51a047745140df9bd04f (diff)
downloadbitcoin-f36a40f7fd948781656e730338a1ae647e7c4928.tar.xz
build: check visibility attributes
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ef759a44b4..e2efdf203b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -346,6 +346,10 @@ fi
AX_CHECK_LINK_FLAG([[-Wl,--large-address-aware]], [LDFLAGS="$LDFLAGS -Wl,--large-address-aware"])
+AX_GCC_FUNC_ATTRIBUTE([visibility])
+AX_GCC_FUNC_ATTRIBUTE([dllexport])
+AX_GCC_FUNC_ATTRIBUTE([dllimport])
+
if test x$use_glibc_compat != xno; then
#__fdelt_chk's params and return type have changed from long unsigned int to long int.