aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWladimir J. van der Laan <laanwj@gmail.com>2015-09-30 00:54:13 +0200
committerWladimir J. van der Laan <laanwj@gmail.com>2015-09-30 00:55:25 +0200
commitc138cf9769635cec57613ec0c8b32123f649d5b4 (patch)
tree024cd7db93afbcd564cd55766c1d54390e520fe2 /configure.ac
parentf6ce59cd3cb2a6e8a89cd3ce929e0efd4221e0c5 (diff)
parentab0b8be8579d6a8fca26ac9ee7f2cffbca8d72e9 (diff)
downloadbitcoin-c138cf9769635cec57613ec0c8b32123f649d5b4.tar.xz
Merge pull request #6736
ab0b8be zmq: update and cleanup build-unix, release-notes, and zmq docs (Johnathan Corgan) 6cebd5d zmq: require version 4.x or newer of libzmq (Johnathan Corgan)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index f0e0a74fe6..d530f8c262 100644
--- a/configure.ac
+++ b/configure.ac
@@ -145,7 +145,7 @@ AC_ARG_ENABLE([zmq],
AC_ARG_WITH([protoc-bindir],[AS_HELP_STRING([--with-protoc-bindir=BIN_DIR],[specify protoc bin path])], [protoc_bin_path=$withval], [])
-# Enable debug
+# Enable debug
AC_ARG_ENABLE([debug],
[AS_HELP_STRING([--enable-debug],
[use debug compiler flags and macros (default is no)])],
@@ -157,11 +157,11 @@ if test "x$enable_debug" = xyes; then
if test "x$GCC" = xyes; then
CFLAGS="$CFLAGS -g3 -O0"
fi
-
+
if test "x$GXX" = xyes; then
CXXFLAGS="$CXXFLAGS -g3 -O0"
fi
-fi
+fi
## TODO: Remove these hard-coded paths and flags. They are here for the sake of
## compatibility with the legacy buildsystem.
@@ -843,10 +843,10 @@ fi
AC_MSG_CHECKING([whether to build ZMQ support])
if test "x$use_zmq" = "xyes"; then
AC_MSG_RESULT([yes])
- PKG_CHECK_MODULES([ZMQ],[libzmq],
+ PKG_CHECK_MODULES([ZMQ],[libzmq >= 4],
[AC_DEFINE([ENABLE_ZMQ],[1],[Define to 1 to enable ZMQ functions])],
[AC_DEFINE([ENABLE_ZMQ],[0],[Define to 1 to enable ZMQ functions])
- AC_MSG_WARN([libzmq not found, disabling])
+ AC_MSG_WARN([libzmq version 4.x or greater not found, disabling])
use_zmq=no])
else
AC_MSG_RESULT([no, --disable-zmq used])