aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuke Dashjr <luke-jr+git@utopios.org>2015-06-06 14:23:38 +0000
committerLuke Dashjr <luke-jr+git@utopios.org>2015-06-06 14:23:38 +0000
commita5a81f7354b3aa3e797d973a7e6840f0e50e6533 (patch)
tree181226c7f76085a6637cb7daacf607e27ba5d806 /configure.ac
parentfb061c3391bca56bba281d85fecf8fb8dd650d86 (diff)
downloadbitcoin-a5a81f7354b3aa3e797d973a7e6840f0e50e6533.tar.xz
configure: Detect (and reject) LibreSSL
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c5d08a0285..a4d932dcca 100644
--- a/configure.ac
+++ b/configure.ac
@@ -677,6 +677,14 @@ else
fi
fi
+AC_CHECK_LIB([crypto],[RAND_egd],[],[
+ AC_ARG_WITH([libressl],
+ [AS_HELP_STRING([--with-libressl],[Build with system LibreSSL (default is no; DANGEROUS; NOT SUPPORTED)])],
+ [AC_MSG_WARN([Detected LibreSSL: This is NOT supported, and may break consensus compatibility!])],
+ [AC_MSG_ERROR([Detected LibreSSL: This is NOT supported, and may break consensus compatibility!])]
+ )
+])
+
CFLAGS_TEMP="$CFLAGS"
LIBS_TEMP="$LIBS"
CFLAGS="$CFLAGS $SSL_CFLAGS $CRYPTO_CFLAGS"