aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndriy Voskoboinyk <andriivos@gmail.com>2015-06-07 04:38:31 +0300
committerAndriy Voskoboinyk <andriivos@gmail.com>2015-06-07 04:54:20 +0300
commit0640a5eb60b06de61f873fd88ae0252f5a11c339 (patch)
treead6c3f95f5facb664098cb55fe07213a91ad9a5e /configure.ac
parent55294a9fb673ab0a7c99b9c18279fe12a5a07890 (diff)
downloadbitcoin-0640a5eb60b06de61f873fd88ae0252f5a11c339.tar.xz
Add an alternate location of endian.h header
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 8676ed316d..05f2426d37 100644
--- a/configure.ac
+++ b/configure.ac
@@ -438,7 +438,7 @@ if test x$TARGET_OS = xdarwin; then
AX_CHECK_LINK_FLAG([[-Wl,-dead_strip]], [LDFLAGS="$LDFLAGS -Wl,-dead_strip"])
fi
-AC_CHECK_HEADERS([endian.h byteswap.h stdio.h stdlib.h unistd.h strings.h sys/types.h sys/stat.h sys/select.h sys/prctl.h])
+AC_CHECK_HEADERS([endian.h sys/endian.h byteswap.h stdio.h stdlib.h unistd.h strings.h sys/types.h sys/stat.h sys/select.h sys/prctl.h])
AC_SEARCH_LIBS([getaddrinfo_a], [anl], [AC_DEFINE(HAVE_GETADDRINFO_A, 1, [Define this symbol if you have getaddrinfo_a])])
AC_SEARCH_LIBS([inet_pton], [nsl resolv], [AC_DEFINE(HAVE_INET_PTON, 1, [Define this symbol if you have inet_pton])])
@@ -447,6 +447,8 @@ AC_CHECK_DECLS([strnlen])
AC_CHECK_DECLS([le16toh, le32toh, le64toh, htole16, htole32, htole64, be16toh, be32toh, be64toh, htobe16, htobe32, htobe64],,,
[#if HAVE_ENDIAN_H
#include <endian.h>
+ #elif HAVE_SYS_ENDIAN_H
+ #include <sys/endian.h>
#endif])
AC_CHECK_DECLS([bswap_16, bswap_32, bswap_64],,,