aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWladimir J. van der Laan <laanwj@gmail.com>2015-06-10 08:08:46 +0200
committerWladimir J. van der Laan <laanwj@gmail.com>2015-06-10 08:08:59 +0200
commitd9a94b70096dee0428a24adba07c0f2608ce3ee7 (patch)
tree0e9f68045aeec416e492f7b9bef9affd2ff262f3 /configure.ac
parent643114f53995c9a662466784953999f073c878ad (diff)
parenta5a81f7354b3aa3e797d973a7e6840f0e50e6533 (diff)
downloadbitcoin-d9a94b70096dee0428a24adba07c0f2608ce3ee7.tar.xz
Merge pull request #6244
a5a81f7 configure: Detect (and reject) LibreSSL (Luke Dashjr)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 05f2426d37..61b6a314af 100644
--- a/configure.ac
+++ b/configure.ac
@@ -679,6 +679,14 @@ else
fi
fi
+AC_CHECK_LIB([crypto],[RAND_egd],[],[
+ AC_ARG_WITH([libressl],
+ [AS_HELP_STRING([--with-libressl],[Build with system LibreSSL (default is no; DANGEROUS; NOT SUPPORTED)])],
+ [AC_MSG_WARN([Detected LibreSSL: This is NOT supported, and may break consensus compatibility!])],
+ [AC_MSG_ERROR([Detected LibreSSL: This is NOT supported, and may break consensus compatibility!])]
+ )
+])
+
CFLAGS_TEMP="$CFLAGS"
LIBS_TEMP="$LIBS"
CFLAGS="$CFLAGS $SSL_CFLAGS $CRYPTO_CFLAGS"