aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWladimir J. van der Laan <laanwj@gmail.com>2015-10-01 18:38:54 +0200
committerWladimir J. van der Laan <laanwj@gmail.com>2015-10-01 18:38:54 +0200
commitbb24835aed822ff1842bbf0920dba592eb48dfd5 (patch)
tree19c0085bbe0a8dd786c8f86418fea0506c49a4c1 /configure.ac
parentbb882d04e8626ba534200a44b58e7ac872a55dd0 (diff)
downloadbitcoin-bb24835aed822ff1842bbf0920dba592eb48dfd5.tar.xz
build: disable -Wself-assign
Prevent these warnings in clang 3.6: ./serialize.h:96:9: warning: explicitly assigning value of variable of type 'uint64_t' (aka 'unsigned long') to itself [-Wself-assign] obj = (obj); ~~~ ^ ~~~
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0803e74ff6..57d89d9d5d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -167,7 +167,7 @@ fi
## compatibility with the legacy buildsystem.
##
if test "x$CXXFLAGS_overridden" = "xno"; then
- CXXFLAGS="$CXXFLAGS -Wall -Wextra -Wformat -Wformat-security -Wno-unused-parameter"
+ CXXFLAGS="$CXXFLAGS -Wall -Wextra -Wformat -Wformat-security -Wno-unused-parameter -Wno-self-assign"
fi
CPPFLAGS="$CPPFLAGS -DHAVE_BUILD_INFO -D__STDC_FORMAT_MACROS"