aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authordexX7 <dexx@bitwatch.co>2015-10-11 22:05:20 +0200
committerdexX7 <dexx@bitwatch.co>2015-10-23 22:09:17 +0200
commit8e3a27bbbfc8d453877bf6521044c64dfbf64610 (patch)
tree05f6baeabb6834656e0f306f2540064f90130fa3 /configure.ac
parentd425877557037b063c5cadcc49ef0582706cff77 (diff)
downloadbitcoin-8e3a27bbbfc8d453877bf6521044c64dfbf64610.tar.xz
Require Python for RPC tests, when using lcov
Because Python is (going to be) used to run the RPC tests, when gathering coverage data with lcov, it is explicitly checked, whether Python is really available.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4318aafa55..13598acd2f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -58,6 +58,7 @@ AC_PATH_TOOL(STRIP, strip)
AC_PATH_TOOL(GCOV, gcov)
AC_PATH_PROG(LCOV, lcov)
AC_PATH_PROG(JAVA, java)
+AC_PATH_PROG(PYTHON, python)
AC_PATH_PROG(GENHTML, genhtml)
AC_PATH_PROG([GIT], [git])
AC_PATH_PROG(CCACHE,ccache)
@@ -351,6 +352,9 @@ if test x$use_lcov = xyes; then
if test x$JAVA = x; then
AC_MSG_ERROR("lcov testing requested but java not found")
fi
+ if test x$PYTHON = x; then
+ AC_MSG_ERROR("lcov testing requested but python not found")
+ fi
if test x$GENHTML = x; then
AC_MSG_ERROR("lcov testing requested but genhtml not found")
fi