aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2023-01-13 15:37:42 +0000
committerfanquake <fanquake@gmail.com>2023-01-28 15:27:23 +0000
commit2b248798d96f794db08b7725730b5fb4e00b9b10 (patch)
tree843db04b832d1a6ba78a0039b5046ff8c608d856 /configure.ac
parent02f5a5e7b5fd7ba35e407d4409202a0e0fed003c (diff)
build: remove --enable-upnp-default from configure
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 1 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index 41c12c0a00..0667515b49 100644
--- a/configure.ac
+++ b/configure.ac
@@ -163,12 +163,6 @@ AC_ARG_WITH([miniupnpc],
[use_upnp=$withval],
[use_upnp=auto])
-AC_ARG_ENABLE([upnp-default],
- [AS_HELP_STRING([--enable-upnp-default],
- [if UPNP is enabled, turn it on at startup (default is no)])],
- [use_upnp_default=$enableval],
- [use_upnp_default=no])
-
AC_ARG_WITH([natpmp],
[AS_HELP_STRING([--with-natpmp],
[enable NAT-PMP (default is yes if libnatpmp is found)])],
@@ -1759,15 +1753,8 @@ if test "$have_miniupnpc" = "no"; then
else
if test "$use_upnp" != "no"; then
AC_MSG_RESULT([yes])
- AC_MSG_CHECKING([whether to build with UPnP enabled by default])
use_upnp=yes
- upnp_setting=0
- if test "$use_upnp_default" != "no"; then
- use_upnp_default=yes
- upnp_setting=1
- fi
- AC_MSG_RESULT([$use_upnp_default])
- AC_DEFINE_UNQUOTED([USE_UPNP],[$upnp_setting],[UPnP support not compiled if undefined, otherwise value (0 or 1) determines default state])
+ AC_DEFINE([USE_UPNP], [1], [Define to 1 if UPnP support should be compiled in.])
if test "$TARGET_OS" = "windows"; then
MINIUPNPC_CPPFLAGS="$MINIUPNPC_CPPFLAGS -DSTATICLIB -DMINIUPNP_STATICLIB"
fi