aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPavel Janík <Pavel@Janik.cz>2015-10-02 07:44:36 +0200
committerPavel Janík <Pavel@Janik.cz>2015-10-02 07:44:36 +0200
commit9ee5ac82f6a6ca0c36527dbc0ca3393af028af7f (patch)
tree39c135e78e2a19e59683f71b50673b49ff0a2568 /configure.ac
parent5ab5dca6f1bb1eccd47ea64834acc4fee0435b73 (diff)
downloadbitcoin-9ee5ac82f6a6ca0c36527dbc0ca3393af028af7f.tar.xz
Rewrite help texts for features enabled by default.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 7 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 9a1029e79f..284c4cd7f5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -69,8 +69,8 @@ PKG_PROG_PKG_CONFIG
# Enable wallet
AC_ARG_ENABLE([wallet],
- [AS_HELP_STRING([--enable-wallet],
- [enable wallet (default is yes)])],
+ [AS_HELP_STRING([--disable-wallet],
+ [disable wallet (enabled by default)])],
[enable_wallet=$enableval],
[enable_wallet=yes])
@@ -87,7 +87,7 @@ AC_ARG_ENABLE([upnp-default],
[use_upnp_default=no])
AC_ARG_ENABLE(tests,
- AS_HELP_STRING([--enable-tests],[compile tests (default is yes)]),
+ AS_HELP_STRING([--disable-tests],[do not compile tests (default is to compile)]),
[use_tests=$enableval],
[use_tests=yes])
@@ -108,8 +108,8 @@ AC_ARG_WITH([qrencode],
[use_qr=auto])
AC_ARG_ENABLE([hardening],
- [AS_HELP_STRING([--enable-hardening],
- [attempt to harden the resulting executables (default is yes)])],
+ [AS_HELP_STRING([--disable-hardening],
+ [do not attempt to harden the resulting executables (default is to harden)])],
[use_hardening=$enableval],
[use_hardening=yes])
@@ -120,8 +120,8 @@ AC_ARG_ENABLE([reduce-exports],
[use_reduce_exports=no])
AC_ARG_ENABLE([ccache],
- [AS_HELP_STRING([--enable-ccache],
- [use ccache for building (default is yes if ccache is found)])],
+ [AS_HELP_STRING([--disable-ccache],
+ [do not use ccache for building (default is to use if found)])],
[use_ccache=$enableval],
[use_ccache=auto])