aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGavin Andresen <gavinandresen@gmail.com>2015-07-13 14:28:03 -0400
committerGavin Andresen <gavinandresen@gmail.com>2015-07-15 14:05:50 -0400
commit83b48c89718e7b3fc2b180be992446a068f7fdcc (patch)
tree9763d5dda6683caca6cdd968e4f535c59a25da13 /configure.ac
parent5121c68657fb90baa50b709adcc48348c4876783 (diff)
downloadbitcoin-83b48c89718e7b3fc2b180be992446a068f7fdcc.tar.xz
configure --enable-debug changes
Three changes to how configure --enable-debug behaves: 1. Preserve user-passed CXXFLAGS/CFLAGS 2. Compile with -DDEBUG_LOCKORDER 3. Add -DDEBUG -DDEBUG_LOCKORDER to CPPFLAGS (since they are preprocessor options)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 8a54c2f76e..7f90b5f395 100644
--- a/configure.ac
+++ b/configure.ac
@@ -147,12 +147,13 @@ AC_ARG_ENABLE([debug],
[enable_debug=no])
if test "x$enable_debug" = xyes; then
+ CPPFLAGS="$CPPFLAGS -DDEBUG -DDEBUG_LOCKORDER"
if test "x$GCC" = xyes; then
- CFLAGS="-g3 -O0 -DDEBUG"
+ CFLAGS="$CFLAGS -g3 -O0"
fi
if test "x$GXX" = xyes; then
- CXXFLAGS="-g3 -O0 -DDEBUG"
+ CXXFLAGS="$CXXFLAGS -g3 -O0"
fi
fi