aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWladimir J. van der Laan <laanwj@gmail.com>2015-06-01 11:14:44 +0200
committerWladimir J. van der Laan <laanwj@gmail.com>2015-06-01 11:14:44 +0200
commit7fd5b801ff16d748b5ca13ded09ed5da8eacf7e7 (patch)
tree6957a4dfdefe76952ac8078bd74fb64bdbdf763a /configure.ac
parent3e8ccc765a6d02b701ebc40e556e32e4c0613987 (diff)
downloadbitcoin-7fd5b801ff16d748b5ca13ded09ed5da8eacf7e7.tar.xz
build: disable optional use of gmp in internal secp256k1 build
Until secp256k1 is used for verification there is no reason for Bitcoin Core's secp256k1 to link against gmp, even if available. Pass a flag to configure to override the bignum implementation. This fixes a crash at runtime on ppc64 reported by @gmaxwell.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 6dd03ea408..8676ed316d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -885,7 +885,7 @@ PKGCONFIG_LIBDIR_TEMP="$PKG_CONFIG_LIBDIR"
unset PKG_CONFIG_LIBDIR
PKG_CONFIG_LIBDIR="$PKGCONFIG_LIBDIR_TEMP"
-ac_configure_args="${ac_configure_args} --disable-shared --with-pic"
+ac_configure_args="${ac_configure_args} --disable-shared --with-pic --with-bignum=no"
AC_CONFIG_SUBDIRS([src/secp256k1])
AC_OUTPUT