aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWladimir J. van der Laan <laanwj@gmail.com>2014-09-01 10:28:27 +0200
committerWladimir J. van der Laan <laanwj@gmail.com>2014-09-01 10:28:33 +0200
commit107922663b9a53f37a0201ed2f211b1292b686bf (patch)
tree2cee619e19660eef69c6d79d247ad4f48e341217 /configure.ac
parent01113f7b434f0e7a374449a289b3da398bbe4d2c (diff)
parentb144a74a08a856997f48a3c83f0bd080cf9432f9 (diff)
downloadbitcoin-107922663b9a53f37a0201ed2f211b1292b686bf.tar.xz
Merge pull request #4767
b144a74 depends: bump miniupnpc to 1.9.20140701. (Cory Fields) f628127 depends: bump openssl to 1.0.1i (Cory Fields) 9f7f504 build: add -DMINIUPNP_STATICLIB for new version (Cory Fields)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5a2d7e8e41..6dc71292df 100644
--- a/configure.ac
+++ b/configure.ac
@@ -690,7 +690,7 @@ else
AC_MSG_RESULT($use_upnp_default)
AC_DEFINE_UNQUOTED([USE_UPNP],[$upnp_setting],[UPnP support not compiled if undefined, otherwise value (0 or 1) determines default state])
if test x$TARGET_OS = xwindows; then
- CPPFLAGS="$CPPFLAGS -DSTATICLIB"
+ MINIUPNPC_CPPFLAGS="-DSTATICLIB -DMINIUPNP_STATICLIB"
fi
else
AC_MSG_RESULT(no)
@@ -794,6 +794,7 @@ AC_SUBST(LEVELDB_TARGET_FLAGS)
AC_SUBST(BUILD_TEST)
AC_SUBST(BUILD_QT)
AC_SUBST(BUILD_TEST_QT)
+AC_SUBST(MINIUPNPC_CPPFLAGS)
AC_CONFIG_FILES([Makefile src/Makefile share/setup.nsi share/qt/Info.plist])
AC_CONFIG_FILES([qa/pull-tester/run-bitcoind-for-test.sh],[chmod +x qa/pull-tester/run-bitcoind-for-test.sh])
AC_CONFIG_FILES([qa/pull-tester/build-tests.sh],[chmod +x qa/pull-tester/build-tests.sh])