aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWladimir J. van der Laan <laanwj@gmail.com>2015-10-01 18:38:54 +0200
committerLuke Dashjr <luke-jr+git@utopios.org>2015-10-14 08:20:38 +0000
commit9e451578152d297a69734bef5443b31ad67433f2 (patch)
tree71175990e6c50f1eed82f1a9b5caa5aafa42ca3e /configure.ac
parent33d6825c6f91e99de65555d5f869134cfa54d967 (diff)
downloadbitcoin-9e451578152d297a69734bef5443b31ad67433f2.tar.xz
build: disable -Wself-assign
Prevent these warnings in clang 3.6: ./serialize.h:96:9: warning: explicitly assigning value of variable of type 'uint64_t' (aka 'unsigned long') to itself [-Wself-assign] obj = (obj); ~~~ ^ ~~~
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index fd74aef269..aec1b0145b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -160,7 +160,7 @@ fi
## compatibility with the legacy buildsystem.
##
if test "x$CXXFLAGS_overridden" = "xno"; then
- CXXFLAGS="$CXXFLAGS -Wall -Wextra -Wformat -Wformat-security -Wno-unused-parameter"
+ CXXFLAGS="$CXXFLAGS -Wall -Wextra -Wformat -Wformat-security -Wno-unused-parameter -Wno-self-assign"
fi
CPPFLAGS="$CPPFLAGS -DBOOST_SPIRIT_THREADSAFE -DHAVE_BUILD_INFO -D__STDC_FORMAT_MACROS"