aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPavel Janík <Pavel@Janik.cz>2014-11-30 09:56:20 +0100
committerPavel Janík <Pavel@Janik.cz>2014-11-30 09:56:20 +0100
commit4c69ebed44789be056a7b713bed43e5d3b3a5542 (patch)
treedd1317c22d876c381ea6416e2287d7d216b692e8 /configure.ac
parent5270817180c7caae4d6c1dacb01605483d52eb48 (diff)
downloadbitcoin-4c69ebed44789be056a7b713bed43e5d3b3a5542.tar.xz
Add /opt/local/include/db48 only if it exists.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 9814197af3..c4c21eaf4f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -244,8 +244,12 @@ case $host in
AC_CHECK_PROG([PORT],port, port)
if test x$PORT = xport; then
dnl add default macports paths
- CPPFLAGS="$CPPFLAGS -isystem /opt/local/include -I/opt/local/include/db48"
- LIBS="$LIBS -L/opt/local/lib -L/opt/local/lib/db48"
+ CPPFLAGS="$CPPFLAGS -isystem /opt/local/include"
+ LIBS="$LIBS -L/opt/local/lib"
+ if test -d /opt/local/include/db48; then
+ CPPFLAGS="$CPPFLAGS -I/opt/local/include/db48"
+ LIBS="$LIBS -L/opt/local/lib/db48"
+ fi
fi
AC_CHECK_PROG([BREW],brew, brew)