aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPavel Janík <Pavel@Janik.cz>2014-11-21 10:38:27 +0100
committerPavel Janík <Pavel@Janik.cz>2014-11-24 10:28:24 +0100
commit494f6e7d353c63a85a2c6d4c6b2eb8e643934d60 (patch)
tree8f29867d2c1e23d90aeab863051cbd7b40b18b5e /configure.ac
parentc24d07554b18f69a9c5ebf79b48af90d63f16ccb (diff)
downloadbitcoin-494f6e7d353c63a85a2c6d4c6b2eb8e643934d60.tar.xz
Check for strnlen and provide it if it is not found.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6784521d81..1814180864 100644
--- a/configure.ac
+++ b/configure.ac
@@ -421,6 +421,8 @@ AC_CHECK_HEADERS([endian.h stdio.h stdlib.h unistd.h strings.h sys/types.h sys/s
AC_SEARCH_LIBS([getaddrinfo_a], [anl], [AC_DEFINE(HAVE_GETADDRINFO_A, 1, [Define this symbol if you have getaddrinfo_a])])
AC_SEARCH_LIBS([inet_pton], [nsl resolv], [AC_DEFINE(HAVE_INET_PTON, 1, [Define this symbol if you have inet_pton])])
+AC_CHECK_DECLS([strnlen])
+
AC_CHECK_DECLS([le32toh, le64toh, htole32, htole64, be32toh, be64toh, htobe32, htobe64],,,
[#if HAVE_ENDIAN_H
#include <endian.h>