aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWladimir J. van der Laan <laanwj@gmail.com>2015-06-01 11:14:44 +0200
committerWladimir J. van der Laan <laanwj@gmail.com>2015-06-02 08:41:25 +0200
commitdfdb6dd052416da726db6c2e5f76e875cf08c507 (patch)
treea629d9d832a54ed02756645217b20f1c6f3e13b8 /configure.ac
parentb4bbad18ef0d3b1643d2c78c911e854b777330b8 (diff)
downloadbitcoin-dfdb6dd052416da726db6c2e5f76e875cf08c507.tar.xz
build: disable optional use of gmp in internal secp256k1 build
Until secp256k1 is used for verification there is no reason for Bitcoin Core's secp256k1 to link against gmp, even if available. Pass a flag to configure to override the bignum implementation. This fixes a crash at runtime on ppc64 reported by @gmaxwell. Github-Pull: #6210 Rebased-From: 7fd5b801ff16d748b5ca13ded09ed5da8eacf7e7
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 50e4a0ee33..091feebd13 100644
--- a/configure.ac
+++ b/configure.ac
@@ -885,7 +885,7 @@ PKGCONFIG_LIBDIR_TEMP="$PKG_CONFIG_LIBDIR"
unset PKG_CONFIG_LIBDIR
PKG_CONFIG_LIBDIR="$PKGCONFIG_LIBDIR_TEMP"
-ac_configure_args="${ac_configure_args} --disable-shared --with-pic"
+ac_configure_args="${ac_configure_args} --disable-shared --with-pic --with-bignum=no"
AC_CONFIG_SUBDIRS([src/secp256k1])
AC_OUTPUT