aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWladimir J. van der Laan <laanwj@gmail.com>2014-07-04 08:38:25 +0200
committerWladimir J. van der Laan <laanwj@gmail.com>2014-07-04 08:40:01 +0200
commite81e2e8f7cdee307227f150a6a2408c01fcafbf2 (patch)
treed181908dfdf893362b7cd5eae164f65b2fa05d57 /configure.ac
parent81efcd76e644d52e2296fd95c594ab49b7b3fca5 (diff)
parentcaf6150e9785da408f1e603ae70eae25b5202d98 (diff)
downloadbitcoin-e81e2e8f7cdee307227f150a6a2408c01fcafbf2.tar.xz
Merge pull request #4421
caf6150 Use async name resolving to improve net thread responsiveness (Huang Le)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2a4636e360..dcaec0d4b0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -370,6 +370,8 @@ if test x$TARGET_OS = xdarwin; then
fi
AC_CHECK_HEADERS([endian.h stdio.h stdlib.h unistd.h strings.h sys/types.h sys/stat.h sys/select.h])
+AC_SEARCH_LIBS([getaddrinfo_a], [anl], [AC_DEFINE(HAVE_GETADDRINFO_A, 1, [Define this symbol if you have getaddrinfo_a])])
+AC_SEARCH_LIBS([inet_pton], [nsl resolv], [AC_DEFINE(HAVE_INET_PTON, 1, [Define this symbol if you have inet_pton])])
AC_CHECK_DECLS([le32toh, le64toh, htole32, htole64, be32toh, be64toh, htobe32, htobe64],,,
[#if HAVE_ENDIAN_H