aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCory Fields <cory-nospam-@coryfields.com>2014-06-03 23:42:53 -0400
committerCory Fields <cory-nospam-@coryfields.com>2014-07-17 22:13:40 -0400
commitab123ad4d6da65800a1cf4cf45a7171d97a77254 (patch)
tree432d9ff42ceed9a7f4f3ed37649c04d01fc04550 /configure.ac
parente8d4cb807169dd56e8efc753521a94368dd2f69d (diff)
downloadbitcoin-ab123ad4d6da65800a1cf4cf45a7171d97a77254.tar.xz
build: allow linux and osx to build against static qt5
This is the first part of a huge effort to rework the handling of dependencies. To start, this change allows all supported platforms to build against a static Qt. 5.2.1 and 5.3 have been successfully tested against osx64, win32, win64, linux32, and linux64. It also makes a small change to the windows config, to allow linking against qt builds with or without built-in libjpeg/libpng/libpcre/libz. The actual build processes to take advantage of these changes (for gitian and pull-tester) are coming soon. Until then, this should be a no-op.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d3500b4d93..b454ac515f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -258,6 +258,9 @@ case $host in
CPPFLAGS="$CPPFLAGS -DMAC_OSX"
;;
+ *linux*)
+ TARGET_OS=linux
+ ;;
*)
;;
esac