aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCory Fields <cory-nospam-@coryfields.com>2014-11-18 15:49:56 -0500
committerCory Fields <cory-nospam-@coryfields.com>2014-11-19 22:31:11 -0500
commit9ed8979e294fb7a42e26a6b6541f614554663bea (patch)
treebd81e18106d0eed2b947786e875372f70d69009d /configure.ac
parent19df238a7ba7a6cdfbf48bc663c39ddbf9f6c7d0 (diff)
downloadbitcoin-9ed8979e294fb7a42e26a6b6541f614554663bea.tar.xz
build: fix static dll link for mingw
dll's are no longer dynamically linked to libgcc/libstdc++/libssp
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 70a9c15ffb..77ab5eb03c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -226,6 +226,15 @@ case $host in
*) AC_MSG_ERROR("Could not determine win32/win64 for installer") ;;
esac
AC_SUBST(WINDOWS_BITS)
+
+ dnl libtool insists upon adding -nostdlib and a list of objects/libs to link against.
+ dnl That breaks our ability to build dll's with static libgcc/libstdc++/libssp. Override
+ dnl its command here, with the predeps/postdeps removed, and -static inserted. Postdeps are
+ dnl also overridden to prevent their insertion later.
+ dnl This should only affect dll's.
+ archive_cmds_CXX="\$CC -shared \$libobjs \$deplibs \$compiler_flags -static -o \$output_objdir/\$soname \${wl}--enable-auto-image-base -Xlinker --out-implib -Xlinker \$lib"
+ postdeps_CXX=
+
;;
*darwin*)
TARGET_OS=darwin