aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCory Fields <cory-nospam-@coryfields.com>2014-08-08 15:19:49 -0400
committerCory Fields <cory-nospam-@coryfields.com>2014-08-08 15:20:14 -0400
commit8021cf8dbc0aafa15a481c6d9348771a0d0405ff (patch)
treeb2d6e626b02aa6b4697bacb986f7e57b42cb8d2f /configure.ac
parent36065cc529bb9be5655fcaaad2746edb7b6f4ddb (diff)
downloadbitcoin-8021cf8dbc0aafa15a481c6d9348771a0d0405ff.tar.xz
build: fix FDELT_TYPE configure check
This probably never worked properly. Confirmed working now with every compiler I throw at it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0b2a429e02..ffd05ae4f8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -332,7 +332,10 @@ if test x$use_glibc_compat != xno; then
#__fdelt_chk's params and return type have changed from long unsigned int to long int.
# See which one is present here.
AC_MSG_CHECKING(__fdelt_chk type)
- AC_TRY_COMPILE([#define __USE_FORTIFY_LEVEL 2
+ AC_TRY_COMPILE([#ifdef _FORTIFY_SOURCE
+ #undef _FORTIFY_SOURCE
+ #endif
+ #define _FORTIFY_SOURCE 2
#include <sys/select.h>
extern "C" long unsigned int __fdelt_warn(long unsigned int);],[],
[ fdelt_type="long unsigned int"],