aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorCarl Dong <contact@carldong.me>2020-11-17 13:10:01 -0500
committerCarl Dong <contact@carldong.me>2021-01-21 10:58:12 -0500
commitf3835dc6a3732dcd4afbb5987f84dc27f2bf55af (patch)
tree203c26d5830ac55aedad3ff0a1a09fa27e918786 /Makefile.am
parentc9eb4cf3a0f81bfd72f06fd43b5610f0a4f5e804 (diff)
downloadbitcoin-f3835dc6a3732dcd4afbb5987f84dc27f2bf55af.tar.xz
build: Make xorrisofs reproducible with -volume_date
We need this to be after a '--' as '-volume_date' is a xorriso flag, not a xorrisofs flag. See the respective man pages. For more details: https://issues.guix.info/issue/35283#2
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index c554f630ae..7c4b971ea3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -141,7 +141,7 @@ $(APP_DIST_DIR)/Applications:
$(APP_DIST_EXTRAS): $(APP_DIST_DIR)/$(OSX_APP)/Contents/MacOS/Bitcoin-Qt
$(OSX_TEMP_ISO): $(APP_DIST_EXTRAS)
- $(XORRISOFS) -D -l -V "$(OSX_VOLNAME)" -no-pad -r -dir-mode 0755 -o $@ dist
+ $(XORRISOFS) -D -l -V "$(OSX_VOLNAME)" -no-pad -r -dir-mode 0755 -o $@ dist -- $(if $(SOURCE_DATE_EPOCH),-volume_date all_file_dates =$(SOURCE_DATE_EPOCH))
$(OSX_DMG): $(OSX_TEMP_ISO)
$(DMG) dmg "$<" "$@"