aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2020-08-08 15:36:45 +0300
committerHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2020-08-08 22:53:15 +0300
commitc71bdf93d7bb2b7aa368a49538edb9c3df2c74f8 (patch)
tree1c2e76b4c3b953f8f76e54beceac4df59bd3b5c7 /Makefile.am
parente349eeeb2c9219908686f430b3d74d1b2d5c1106 (diff)
downloadbitcoin-c71bdf93d7bb2b7aa368a49538edb9c3df2c74f8.tar.xz
build, test: Add support for llvm-cov
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 75a164f49e..2a72c23173 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -65,7 +65,7 @@ OSX_PACKAGING = $(OSX_DEPLOY_SCRIPT) $(OSX_FANCY_PLIST) $(OSX_INSTALLER_ICONS) \
$(top_srcdir)/contrib/macdeploy/detached-sig-apply.sh \
$(top_srcdir)/contrib/macdeploy/detached-sig-create.sh
-COVERAGE_INFO = baseline.info \
+COVERAGE_INFO = $(COV_TOOL_WRAPPER) baseline.info \
test_bitcoin_filtered.info total_coverage.info \
baseline_filtered.info functional_test.info functional_test_filtered.info \
test_bitcoin_coverage.info test_bitcoin.info fuzz.info fuzz_coverage.info
@@ -192,7 +192,11 @@ LCOV_FILTER_PATTERN = \
-p "src/secp256k1" \
-p "depends"
-baseline.info:
+$(COV_TOOL_WRAPPER):
+ @echo 'exec $(COV_TOOL) "$$@"' > $(COV_TOOL_WRAPPER)
+ @chmod +x $(COV_TOOL_WRAPPER)
+
+baseline.info: $(COV_TOOL_WRAPPER)
$(LCOV) -c -i -d $(abs_builddir)/src -o $@
baseline_filtered.info: baseline.info