aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDmitry Goncharov <dgoncharov@users.sf.net>2021-06-13 11:38:59 -0400
committerDmitry Goncharov <dgoncharov@users.sf.net>2021-06-24 23:08:26 -0400
commitfb7be92b094477131140b58a4e3ae98366b93e76 (patch)
tree50ce7c94e9b040f738a0d5b07e6f6752abc2a549 /Makefile.am
parente3d644a127e1432fbaf1c9d719edb28301943c60 (diff)
downloadbitcoin-fb7be92b094477131140b58a4e3ae98366b93e76.tar.xz
Mark print-% target as phony.
.PHONY does not take patterns (such as print-%) as prerequisites. Have print-% depend on FORCE and mark FORCE as phony. $ # on master $ make print-host host=x86_64-pc-linux-gnu $ touch print-host $ make print-host make: 'print-host' is up to date. $ $ git co mark_print_as_phony Switched to branch 'mark_print_as_phony' $ make print-host host=x86_64-pc-linux-gnu $ touch FORCE $ make print-host host=x86_64-pc-linux-gnu
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index d84dab1842..49d5d83e82 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,7 +3,7 @@
# file COPYING or http://www.opensource.org/licenses/mit-license.php.
# Pattern rule to print variables, e.g. make print-top_srcdir
-print-%:
+print-%: FORCE
@echo '$*'='$($*)'
ACLOCAL_AMFLAGS = -I build-aux/m4