aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorCarl Dong <contact@carldong.me>2020-12-11 10:20:58 -0500
committerCarl Dong <contact@carldong.me>2021-02-03 12:10:02 -0500
commitb3bdff42b5a7b4b956da700b187a7254daac54ae (patch)
treeef7983396daaffbe44accfc2f7e663bce8046499 /Makefile.am
parentf72d80b07af8ecbb2f9df1e87344eb465186f19d (diff)
downloadbitcoin-b3bdff42b5a7b4b956da700b187a7254daac54ae.tar.xz
build: Proper quoting for var printing targets
Previously, if the value contained syntax that was meaningful to make, the printing would fail. Quoting properly avoids this.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index f6b824faaa..66be768277 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,7 +4,7 @@
# Pattern rule to print variables, e.g. make print-top_srcdir
print-%:
- @echo $* = $($*)
+ @echo '$*' = '$($*)'
ACLOCAL_AMFLAGS = -I build-aux/m4
SUBDIRS = src