aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authoreugene <elzeigel@gmail.com>2020-09-02 14:59:13 -0400
committereugene <elzeigel@gmail.com>2020-09-02 15:17:13 -0400
commit9bdde3c802e1512cbcd8ae8f7db72b6fe13ea829 (patch)
treeb8b651f913feceaa5b9adfd81b82a6a0c6e40881 /Makefile.am
parentc157a50694545090cb1c7e69123fe4709bd5a279 (diff)
downloadbitcoin-9bdde3c802e1512cbcd8ae8f7db72b6fe13ea829.tar.xz
build: add /usr/local/ to LCOV_FILTER_PATTERN for macOS builds
With this commit, the files in /usr/local/ will not be included in `make cov` or `make cov_fuzz` coverage reports. This behavior could be observed when generating the reports on macOS with brew-installed clang.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 1d6358b1d5..8cdd3ff647 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -181,6 +181,7 @@ $(BITCOIN_WALLET_BIN): FORCE
if USE_LCOV
LCOV_FILTER_PATTERN = \
+ -p "/usr/local/" \
-p "/usr/include/" \
-p "/usr/lib/" \
-p "/usr/lib64/" \