aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorWladimir J. van der Laan <laanwj@protonmail.com>2020-11-24 13:02:08 +0100
committerWladimir J. van der Laan <laanwj@protonmail.com>2020-12-03 12:15:12 +0100
commit5bab08df175db3a4283596515e498fc5a4d0dab9 (patch)
tree95ec579d3e339c89affc428edbbecd027b47aae9 /Makefile.am
parent0918eb49d5afabdf811da5eeb89f4f2c22d12de2 (diff)
downloadbitcoin-5bab08df175db3a4283596515e498fc5a4d0dab9.tar.xz
contrib: Add test for ELF symbol-check
Check both failure cases: - Use a glibc symbol from a version that is too new - Use a symbol from a library that is not in the allowlist And also check a conforming binary. Adding a similar check for Windows PE can be done in a separate PR.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c8af4228f3..798f8b3524 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -359,4 +359,5 @@ if TARGET_WINDOWS
endif
if TARGET_LINUX
$(AM_V_at) $(PYTHON) $(top_srcdir)/contrib/devtools/test-security-check.py TestSecurityChecks.test_ELF
+ $(AM_V_at) $(PYTHON) $(top_srcdir)/contrib/devtools/test-symbol-check.py TestSymbolChecks.test_ELF
endif