aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2020-12-21 08:38:25 +0200
committerHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2021-03-18 20:58:13 +0200
commit3d31abbaaad599443ec5ffee90ddb6989a625277 (patch)
treec98e33d76832f1c939397ab533703c7f3d16effa /Makefile.am
parent92990e25b7e5d02651ffa27f2d57c4c2c190668e (diff)
downloadbitcoin-3d31abbaaad599443ec5ffee90ddb6989a625277.tar.xz
build: Make Windows-specific targets available for Windows builds only
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index ce513426dd..be62c3e6a9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -78,6 +78,7 @@ COVERAGE_INFO = $(COV_TOOL_WRAPPER) baseline.info \
dist-hook:
-$(GIT) archive --format=tar HEAD -- src/clientversion.cpp | $(AMTAR) -C $(top_distdir) -xf -
+if TARGET_WINDOWS
$(BITCOIN_WIN_INSTALLER): all-recursive
$(MKDIR_P) $(top_builddir)/release
STRIPPROG="$(STRIP)" $(INSTALL_STRIP_PROGRAM) $(BITCOIND_BIN) $(top_builddir)/release
@@ -90,6 +91,9 @@ $(BITCOIN_WIN_INSTALLER): all-recursive
echo error: could not build $@
@echo built $@
+deploy: $(BITCOIN_WIN_INSTALLER)
+endif
+
if TARGET_DARWIN
$(OSX_APP)/Contents/PkgInfo:
$(MKDIR_P) $(@D)
@@ -167,10 +171,6 @@ appbundle: $(OSX_APP_BUILT)
deploy: $(OSX_DMG)
endif
-if TARGET_WINDOWS
-deploy: $(BITCOIN_WIN_INSTALLER)
-endif
-
$(BITCOIN_QT_BIN): FORCE
$(MAKE) -C src qt/$(@F)