aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorCarl Dong <contact@carldong.me>2020-04-27 16:05:57 -0400
committerCarl Dong <contact@carldong.me>2020-04-28 10:36:38 -0400
commitfa791da02f9684e3fd554b687fb692ae6a23d65a (patch)
treec8480045dc36f5a25eccc33103cbab9cfe6c0792 /Makefile.am
parent14701604d0904bc5bbf1c67de08f8ee6d3215523 (diff)
downloadbitcoin-fa791da02f9684e3fd554b687fb692ae6a23d65a.tar.xz
nsis: Specify OutFile path only once
Previously, we would specify the makensis output file path twice: 1. At the top of Makefile.am as BITCOIN_WIN_INSTALLER, and 2. In share/setup.nsi.ini This commit uses the -X flag of makensis to eliminate the need for the second instance mentioned above, referring makensis directly to the value of BITCOIN_WIN_INSTALLER
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index c35f5080aa..1c39f1940c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -80,7 +80,7 @@ $(BITCOIN_WIN_INSTALLER): all-recursive
STRIPPROG="$(STRIP)" $(INSTALL_STRIP_PROGRAM) $(BITCOIN_CLI_BIN) $(top_builddir)/release
STRIPPROG="$(STRIP)" $(INSTALL_STRIP_PROGRAM) $(BITCOIN_TX_BIN) $(top_builddir)/release
STRIPPROG="$(STRIP)" $(INSTALL_STRIP_PROGRAM) $(BITCOIN_WALLET_BIN) $(top_builddir)/release
- @test -f $(MAKENSIS) && $(MAKENSIS) -V2 $(top_builddir)/share/setup.nsi || \
+ @test -f $(MAKENSIS) && $(MAKENSIS) -V2 $(top_builddir)/share/setup.nsi -X'OutFile "$@"' || \
echo error: could not build $@
@echo built $@