aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorCarl Dong <contact@carldong.me>2020-05-01 14:27:57 -0400
committerCarl Dong <contact@carldong.me>2020-05-01 14:27:57 -0400
commit27e63e01cce368d67092de8f0c736927d6f6aa69 (patch)
tree6929526b948e48a276d521b812c6ddd775b580ae /Makefile.am
parent1f2c39a30e0f82046c7aecddfda3eb99cb536816 (diff)
downloadbitcoin-27e63e01cce368d67092de8f0c736927d6f6aa69.tar.xz
build: Accomodate makensis v2.x
Apparently the -X flag doesn't work as expected in makensis v2.x For example: makensis -V2 share/setup.nsi -X'OutFile "test.exe"' Will output: OutFile expects 1 parameters, got 0. Usage: OutFile install_output.exe So let's instead construct the file using POSIX-compliant commands and shell constructs
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 1c39f1940c..43790f1c23 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -80,7 +80,7 @@ $(BITCOIN_WIN_INSTALLER): all-recursive
STRIPPROG="$(STRIP)" $(INSTALL_STRIP_PROGRAM) $(BITCOIN_CLI_BIN) $(top_builddir)/release
STRIPPROG="$(STRIP)" $(INSTALL_STRIP_PROGRAM) $(BITCOIN_TX_BIN) $(top_builddir)/release
STRIPPROG="$(STRIP)" $(INSTALL_STRIP_PROGRAM) $(BITCOIN_WALLET_BIN) $(top_builddir)/release
- @test -f $(MAKENSIS) && $(MAKENSIS) -V2 $(top_builddir)/share/setup.nsi -X'OutFile "$@"' || \
+ @test -f $(MAKENSIS) && echo 'OutFile "$@"' | cat $(top_builddir)/share/setup.nsi - | $(MAKENSIS) -V2 - || \
echo error: could not build $@
@echo built $@